[patchteam] twisted fix for installing zope
authordingo <dingo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Mar 2010 22:34:30 +0000 (22:34 +0000)
committerdingo <dingo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Mar 2010 22:34:30 +0000 (22:34 +0000)
Signed off by alexander@sulfrian.net

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20169 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/twisted/Makefile

index 4187773..2dd3942 100644 (file)
@@ -218,11 +218,17 @@ define Build/Compile
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
                TWISTED_SUBPROJECTS="$(TWISTED_SUBPROJECTS)" \
+               PYTHONPATH="$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)" \
        )
        $(call Build/Compile/PyMod,zope.interface-$(ZOPE_IF_VER), \
                install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
+               PYTHONPATH="$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)" \
        )
        $(SED) 's,#!$(PYTHON),#!/usr/bin/python,' $(PKG_INSTALL_DIR)/usr/bin/*
+
+       $(CP) -a \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/zope.interface-*.egg/zope \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/
 endef
 
 $(eval $(call PyPackage,twisted))