pypcap: fix compile error with the new libpcap
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Jul 2009 13:14:28 +0000 (13:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Jul 2009 13:14:28 +0000 (13:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16691 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/pypcap/Makefile

index ed7d028..bbf1fc8 100644 (file)
@@ -33,6 +33,8 @@ define PyPackage/python-pcap/filespec
 +|$(PYTHON_PKG_DIR)/pcap.so
 endef
 
+TARGET_CFLAGS += -DHAVE_PCAP_FILE=1
+
 define Build/Compile
        $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \