hostapd: fix wpad compile on powerpc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Feb 2010 18:28:46 +0000 (18:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Feb 2010 18:28:46 +0000 (18:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19663 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile

index 8823672..b68b5f9 100644 (file)
@@ -224,7 +224,8 @@ endef
 define Build/Compile/wpad
        echo ` \
                $(call Build/RunMake,hostapd,-s MULTICALL=1 dump_cflags); \
-               $(call Build/RunMake,wpa_supplicant,-s dump_cflags) | sed -e 's,$(TARGET_CFLAGS),,' \
+               $(call Build/RunMake,wpa_supplicant,-s dump_cflags) | \
+               sed -e 's,-n ,,g' -e 's,$(TARGET_CFLAGS),,' \
        ` > $(PKG_BUILD_DIR)/.cflags
        $(call Build/RunMake,hostapd, \
                CFLAGS="$$$$(cat $(PKG_BUILD_DIR)/.cflags)" \