luci-0.10: merge trunk
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 9 May 2011 23:04:26 +0000 (23:04 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 9 May 2011 23:04:26 +0000 (23:04 +0000)
23 files changed:
applications/luci-ffwizard/luasrc/model/cbi/freifunk/ffwizard.lua
build/i18n-po2lua.pl [deleted file]
contrib/package/luci/Makefile
modules/freifunk/luasrc/view/freifunk/adminindex.htm
modules/freifunk/root/etc/config/freifunk
modules/freifunk/root/etc/config/profile_bergischesland
modules/freifunk/root/etc/config/profile_berlin
modules/freifunk/root/etc/config/profile_duesseldorf
modules/freifunk/root/etc/config/profile_hannover
modules/freifunk/root/etc/config/profile_kiberpipa
modules/freifunk/root/etc/config/profile_leipzig
modules/freifunk/root/etc/config/profile_mainz
modules/freifunk/root/etc/config/profile_marburg
modules/freifunk/root/etc/config/profile_neuss
modules/freifunk/root/etc/config/profile_openwireless_bern
modules/freifunk/root/etc/config/profile_potsdam
modules/freifunk/root/etc/config/profile_rosbach
modules/freifunk/root/etc/config/profile_seefeld
modules/freifunk/root/etc/config/profile_wlanljubljana
po/en/base.po
po/ms/base.po
po/no/base.po
po/pl/base.po

index f915cfa..8a6e078 100644 (file)
@@ -36,11 +36,11 @@ local lat = uci:get_first("system", "system", "latitude")
 local lon = uci:get_first("system", "system", "longitude")
 local suffix = uci:get_first(community, "community", "suffix") or "olsr"
 
-luci.i18n.loadc("ffwizard")
+luci.i18n.loadc("freifunk")
 
 -- Check if all necessary variables are available
 if not (community ~= "profile_na" and lat and lon) then
-       luci.http.redirect(luci.dispatcher.build_url("admin", "freifunk", "ffwizard_error"))
+       luci.http.redirect(luci.dispatcher.build_url(unpack(luci.dispatcher.context.requested.path), "freifunk", "ffwizard_error"))
        return
 end
 
@@ -117,7 +117,7 @@ function cbi_meship6(dev)
 end
 
 function cbi_netconf(dev)
-       local d = f:field(Flag, "device_" .. dev , " <b>"  .. dev:upper() .. "</b>", translate("Configure this interface."))
+       local d = f:field(Flag, "device_" .. dev , " <b>"  .. dev:upper() .. "</b>", "Configure this interface.")
        d:depends("netconfig", "1")
        d.rmempty = false
        function d.cfgvalue(self, section)
@@ -321,7 +321,7 @@ function wanproto.write(self, section, value)
        uci:set("network", "wan", "proto", value)
        uci:save("network")
 end
-wanip = f:field(Value, "wanipaddr", translate("IP address"))
+wanip = f:field(Value, "wanipaddr", translate("Ip address"))
 wanip:depends("wanproto", "static")
 function wanip.cfgvalue(self, section)
        return uci:get("network", "wan", "ipaddr")
@@ -381,7 +381,7 @@ function wanpwd.write(self, section, value)
        uci:save("network")
 end
 
-wansec = f:field(Flag, "wansec", translate("Protect LAN"), translate("Check this to protect your LAN from other nodes or clients") .. " (" .. translate("recommended") .. ").")
+wansec = f:field(Flag, "wansec", translate("Protect LAN"), translate("Check this to protect your LAN from other nodes or clients" .. " (" .. translate("recommended") .. ")."))
 wansec.default = "1"
 wansec.rmempty = false
 wansec:depends("wanproto", "static")
@@ -437,7 +437,7 @@ if has_l2gvpn then
 end
 
 if has_hb then
-       hb = f:field(Flag, "hb", translate("Heartbeat"), translate("Allow to transfer anonymous statistics about this node") .. " (" .. translate("recommended") .. ").")
+       hb = f:field(Flag, "hb", translate("Heartbeat"), translate("Allow to transfer anonymous statistics about this node" .. " (" .. translate("recommended") .. ")."))
        hb.rmempty = false
        hb:depends("netconfig", "1")
        function hb.cfgvalue(self, section)
@@ -457,9 +457,9 @@ function f.handle(self, state, data)
                        if data.pw1 then
                                local stat = luci.sys.user.setpasswd("root", data.pw1) == 0
                                if stat then
-                                       f.message = translate("Password successfully changed")
+                                       f.message = translate("a_s_changepw_changed")
                                else
-                                       f.errmessage = translate("Unknown Error")
+                                       f.errmessage = translate("unknownerror")
                                end
                        end
                        data.pw1 = nil
@@ -1045,6 +1045,15 @@ function main.write(self, section, value)
                        uci:set("system", s['.name'], "zonename", "Europe/Berlin")
                        uci:set("system", s['.name'], "timezone", 'CET-1CEST,M3.5.0,M10.5.0/3')
                end)
+
+       -- Create time rdate_servers
+       local rdate = uci:get_all("freifunk", "time")
+       uci:delete_all("system", "time")
+       uci:section("system", "time", "rdate_servers", rdate)
+       rdate.server = rdate.rdate_servers
+       rdate.rdate_servers = ""
+       uci:delete_all("system", "rdate", nil)
+       uci:section("system", "rdate", nil, rdate)
        uci:save("system")
 
        -- Delete old watchdog settings
diff --git a/build/i18n-po2lua.pl b/build/i18n-po2lua.pl
deleted file mode 100755 (executable)
index 5129055..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/usr/bin/perl
-
-@ARGV == 2 || die "Usage: $0 <source-dir> <dest-dir>\n";
-
-my $source_dir  = shift @ARGV;
-my $target_dir  = shift @ARGV;
-
-if( ! -d $target_dir )
-{
-       system('mkdir', '-p', $target_dir);
-}
-
-if( open F, "find $source_dir -type f -name '*.po' |" )
-{
-       while( chomp( my $file = readline F ) )
-       {
-               my ( $lang, $basename ) = $file =~ m{.+/(\w+)/([^/]+)\.po$};
-               $lang = lc $lang;
-               $lang =~ s/_/-/g;
-
-               printf "Generating %-40s ", "$target_dir/$basename.$lang.lmo";
-               system("./build/po2lmo", $file, "$target_dir/$basename.$lang.lmo");
-               print ( -f "$target_dir/$basename.$lang.lmo" ? "done\n" : "empty\n" );
-       }
-
-       close F;
-}
index fcfe695..8c1a947 100644 (file)
@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 
-PKG_BRANCH:=trunk
+PKG_BRANCH:=branches/luci-0.10
 
 ifeq ($(DUMP),)
   USELOCAL:=$(shell grep luci ../../../.project 2>/dev/null >/dev/null && echo 1)
index 58655cc..0188f2e 100644 (file)
@@ -17,7 +17,7 @@ local basicsurl = luci.dispatcher.build_url(luci.dispatcher.context.path[1], "fr
 
 <% if not (hostname and latitude and longitude and location) then%>
 <div class="error">
-       <%:Basic settings are incomplete. Please go to%> <a href='<%=basicsurl%>'><%:Basic settings%></a> <%:and fill out all required fields.%>
+        <%:Basic settings are incomplete. Please go to%> <a href='<%=basicsurl%>'<%:Basic settings%></a> <%:and fill out all required fields.%></p>
 </div>
 <%end%>
 <p />
@@ -35,7 +35,7 @@ local basicsurl = luci.dispatcher.build_url(luci.dispatcher.context.path[1], "fr
        if section.diversity ~= "0" and section.disabled ~= "1" then
                print('<div class="error">' .. translate("Diversity is enabled for device") .. ' <b>' .. device .. '</b>. '
                .. translate("Go to") .. ' <a href="' .. url .. '">' .. translate("wireless settings") .. '</a> ' ..
-               translate("to disable it.") .. '</div><p />')
+               translate(" to disable it.") .. '</div><p />')
        end
 end) %>
 
index 9aa3f27..b000970 100644 (file)
@@ -70,8 +70,8 @@ config 'defaults' 'wifi_iface'
        option 'sw_merge' '1'
 
 config 'defaults' 'interface'
-       option 'netmask' '255.255.0.0'
-       option 'dns' '8.8.8.8 212.204.49.83 141.1.1.1'
+       option 'netmask' '255.0.0.0'
+       option 'dns' '88.198.178.18 141.54.1.1 212.204.49.83 208.67.220.220 208.67.222.222'
 
 config 'defaults' 'alias'
        option 'netmask' '255.255.255.0'
index 0de4543..46ad71c 100644 (file)
@@ -13,3 +13,7 @@ config 'defaults' 'wifi_device'
 
 config 'defaults' 'wifi_iface'
        option 'bssid' '02:40:00:42:42:42'
+
+config 'defaults' 'interface'
+       option 'netmask' '255.255.0.0'
+
index c41144e..a37a6cb 100644 (file)
@@ -10,7 +10,3 @@ config 'community' 'profile'
 
 config 'defaults' 'wifi_device'
        option 'channel' '10'
-
-config 'defaults' 'interface'
-        option 'netmask' '255.0.0.0'
-
index 7327395..64ebbac 100644 (file)
@@ -8,6 +8,9 @@ config 'community' 'profile'
        option 'latitude' '51.22347'
        option 'longitude' '6.78449'
 
+config 'defaults' 'interface'
+       option 'netmask' '255.255.0.0'
+
 config 'defaults' 'wifi_device'
        option 'channel' '3'
 
index 008b6c7..99f2c46 100644 (file)
@@ -10,3 +10,7 @@ config 'community' 'profile'
 
 config 'defaults' 'wifi_iface'
        option 'bssid' 'CA:FF:EE:CA:FF:EE'
+
+config 'defaults' 'interface'
+       option 'netmask' '255.255.0.0'
+
index c2a96e4..628850a 100644 (file)
@@ -13,3 +13,4 @@ config 'defaults' 'wifi_device'
 
 config 'defaults' 'interface'
        option 'dns' '10.14.0.1 208.67.222.220 208.67.220.222'
+       option 'netmask' '255.255.0.0'
index f4dffb8..1418f7a 100644 (file)
@@ -8,7 +8,5 @@ config 'community' 'profile'
        option 'latitude' '51.33348'
        option 'longitude' '12.40297'
 
-config 'defaults' 'interface'
-       option 'netmask' '255.0.0.0'
 
 
index 2d08618..c6cd61d 100644 (file)
@@ -13,3 +13,7 @@ config 'defaults' 'wifi_iface'
 
 config 'defaults' 'wifi_device'
        option 'channel' '1'
+
+config 'defaults' 'interface'
+       option 'netmask' '255.255.0.0'
+
index 18cff80..21ad644 100644 (file)
@@ -10,3 +10,4 @@ config 'community' 'profile'
 
 config 'defaults' 'interface'
        option 'dns' '8.8.8.8 212.204.49.83'
+        option 'netmask' '255.255.0.0'
index 8e30617..5f97d87 100644 (file)
@@ -11,5 +11,8 @@ config 'community' 'profile'
 config 'defaults' 'wifi_device'
        option 'channel' '11'
 
+config 'defaults' 'interface'
+       option 'netmask' '255.255.0.0'
+
 config 'defaults' 'wifi_iface'
        option 'bssid' 'DE:AD:BE:EF:CA:FE'
index 810ad8f..b9f5cbd 100644 (file)
@@ -9,6 +9,7 @@ config 'community' 'profile'
        option 'longitude' '8.769239'
 
 config 'defaults' 'interface'
+       option 'netmask' '255.255.0.0'
        option 'dns' '208.67.222.222 208.67.220.220'
 
 config 'defaults' 'wifi_device'
index a70a29e..ff1d661 100644 (file)
@@ -8,5 +8,8 @@ config 'community' 'profile'
        option 'latitude' '52.39349'
        option 'longitude' '13.06489'
 
+config 'defaults' 'interface'
+       option 'netmask' '255.255.0.0'
+
 config 'defaults' 'wifi_device'
        option 'channel' '13'
index 4444f70..ec07281 100644 (file)
@@ -13,3 +13,6 @@ config 'defaults' 'wifi_device'
 
 config 'defaults' 'wifi_iface'
        option 'bssid' 'D2:CA:FF:EE:BA:BE'
+
+config 'defaults' 'interface'
+        option 'netmask' '255.255.0.0'
index 5d03f7d..f88562d 100644 (file)
@@ -8,6 +8,9 @@ config 'community' 'profile'
        option 'latitude' '48.03485'
        option 'longitude' '11.21279'
 
+config 'defaults' 'interface'
+       option 'netmask' '255.255.255.0'
+
 config 'defaults' 'wifi_device'
        option 'channel' '1'
        option 'bssid' '02:CA:FF:EE:BA:BB'
index eeefbd2..9d76eeb 100644 (file)
@@ -13,3 +13,4 @@ config 'defaults' 'wifi_device'
 
 config 'defaults' 'interface'
        option 'dns' '10.254.0.1 10.254.0.2'
+       option 'netmask' '255.255.0.0'
index 430c3c6..4b8f65e 100644 (file)
@@ -997,9 +997,6 @@ msgstr ""
 msgid "IPv4"
 msgstr ""
 
-msgid "IPv4 Firewall"
-msgstr ""
-
 msgid "IPv4 WAN Status"
 msgstr ""
 
@@ -1009,9 +1006,6 @@ msgstr ""
 msgid "IPv6"
 msgstr "IPv6"
 
-msgid "IPv6 Firewall"
-msgstr ""
-
 msgid "IPv6 Setup"
 msgstr ""
 
@@ -1125,9 +1119,6 @@ msgstr ""
 msgid "Java Script required!"
 msgstr ""
 
-msgid "Join Network"
-msgstr "Join Network"
-
 msgid "Join Network: Settings"
 msgstr ""
 
@@ -1397,12 +1388,6 @@ msgstr ""
 msgid "Mounted file systems"
 msgstr "Mounted file systems"
 
-msgid "Move down"
-msgstr ""
-
-msgid "Move up"
-msgstr ""
-
 msgid "Multicast Rate"
 msgstr "Multicast Rate"
 
@@ -1881,9 +1866,6 @@ msgstr "Save"
 msgid "Save & Apply"
 msgstr "Save & Apply"
 
-msgid "Save &#38; Apply"
-msgstr ""
-
 msgid "Scan"
 msgstr "Scan"
 
@@ -1968,9 +1950,6 @@ msgstr ""
 "Sorry. OpenWrt does not support a system upgrade on this platform.<br /> You "
 "need to manually flash your device."
 
-msgid "Sort"
-msgstr ""
-
 msgid "Source"
 msgstr "Source"
 
@@ -2028,9 +2007,6 @@ msgstr "Stop"
 msgid "Strict order"
 msgstr "Strict order"
 
-msgid "Submit"
-msgstr "Submit"
-
 msgid "Swap Entry"
 msgstr ""
 
@@ -2728,6 +2704,9 @@ msgstr "« Back"
 #~ msgid "Join (Client)"
 #~ msgstr "Join (Client)"
 
+#~ msgid "Join Network"
+#~ msgstr "Join Network"
+
 #~ msgid "Leases"
 #~ msgstr "Leases"
 
@@ -2929,5 +2908,8 @@ msgstr "« Back"
 #~ msgid "Statistics"
 #~ msgstr "Statistics"
 
+#~ msgid "Submit"
+#~ msgstr "Submit"
+
 #~ msgid "zone"
 #~ msgstr "Zone"
index 0a1ec77..c13a95c 100644 (file)
@@ -980,9 +980,6 @@ msgstr ""
 msgid "IPv4"
 msgstr ""
 
-msgid "IPv4 Firewall"
-msgstr ""
-
 msgid "IPv4 WAN Status"
 msgstr ""
 
@@ -992,9 +989,6 @@ msgstr ""
 msgid "IPv6"
 msgstr "Konfigurasi IPv6"
 
-msgid "IPv6 Firewall"
-msgstr ""
-
 msgid "IPv6 Setup"
 msgstr "Setup IPv6"
 
@@ -1108,10 +1102,6 @@ msgstr ""
 msgid "Java Script required!"
 msgstr ""
 
-#, fuzzy
-msgid "Join Network"
-msgstr "Gabung Rangkaian"
-
 msgid "Join Network: Settings"
 msgstr ""
 
@@ -1383,12 +1373,6 @@ msgstr ""
 msgid "Mounted file systems"
 msgstr "Mounted fail sistems"
 
-msgid "Move down"
-msgstr ""
-
-msgid "Move up"
-msgstr ""
-
 msgid "Multicast Rate"
 msgstr "Multicast Rate"
 
@@ -1866,9 +1850,6 @@ msgstr "Simpan"
 msgid "Save & Apply"
 msgstr "Simpan & Melaksanakan"
 
-msgid "Save &#38; Apply"
-msgstr ""
-
 msgid "Scan"
 msgstr "Scan"
 
@@ -1952,9 +1933,6 @@ msgstr ""
 "Maafkan. OpenWRT tidak menyokong meningkatkan sistem pada peron ini. <br /"
 ">Anda perlu flash peranti anda secara manual."
 
-msgid "Sort"
-msgstr ""
-
 msgid "Source"
 msgstr "Sumber"
 
@@ -2013,9 +1991,6 @@ msgstr ""
 msgid "Strict order"
 msgstr "Order Ketat"
 
-msgid "Submit"
-msgstr "Menyerahkan"
-
 msgid "Swap Entry"
 msgstr ""
 
@@ -2706,6 +2681,10 @@ msgstr "« Kembali"
 #~ msgid "Join (Client)"
 #~ msgstr "Gabung dengan (Client)"
 
+#, fuzzy
+#~ msgid "Join Network"
+#~ msgstr "Gabung Rangkaian"
+
 #~ msgid "Leases"
 #~ msgstr "Penyewaan"
 
@@ -2905,5 +2884,8 @@ msgstr "« Kembali"
 #~ msgid "Statistics"
 #~ msgstr "Statistik"
 
+#~ msgid "Submit"
+#~ msgstr "Menyerahkan"
+
 #~ msgid "zone"
 #~ msgstr "Zon"
index cfbd9d6..f17d05a 100644 (file)
@@ -997,9 +997,6 @@ msgstr ""
 msgid "IPv4"
 msgstr ""
 
-msgid "IPv4 Firewall"
-msgstr ""
-
 msgid "IPv4 WAN Status"
 msgstr ""
 
@@ -1009,9 +1006,6 @@ msgstr ""
 msgid "IPv6"
 msgstr "IPv6"
 
-msgid "IPv6 Firewall"
-msgstr ""
-
 msgid "IPv6 Setup"
 msgstr "IPv6 Oppsett"
 
@@ -1124,9 +1118,6 @@ msgstr ""
 msgid "Java Script required!"
 msgstr ""
 
-msgid "Join Network"
-msgstr "Koble til nettverk"
-
 msgid "Join Network: Settings"
 msgstr ""
 
@@ -1394,12 +1385,6 @@ msgstr ""
 msgid "Mounted file systems"
 msgstr "Monterte filsystemer"
 
-msgid "Move down"
-msgstr ""
-
-msgid "Move up"
-msgstr ""
-
 msgid "Multicast Rate"
 msgstr "Multicast hastighet"
 
@@ -1880,9 +1865,6 @@ msgstr "Lagre"
 msgid "Save & Apply"
 msgstr "Lagre & Aktiver"
 
-msgid "Save &#38; Apply"
-msgstr ""
-
 msgid "Scan"
 msgstr "Skann"
 
@@ -1966,9 +1948,6 @@ msgstr ""
 "Beklager. OpenWrt støtter ikke systemoppgradering på denne plattformen.<br /"
 "> Du må flashe enheten manuelt."
 
-msgid "Sort"
-msgstr ""
-
 msgid "Source"
 msgstr "Kilde"
 
@@ -2026,9 +2005,6 @@ msgstr "Stop"
 msgid "Strict order"
 msgstr "Streng overholdelse"
 
-msgid "Submit"
-msgstr "Utfør"
-
 msgid "Swap Entry"
 msgstr ""
 
@@ -2736,6 +2712,9 @@ msgstr "« Tilbake"
 #~ msgid "Join (Client)"
 #~ msgstr "Koble til (klient)"
 
+#~ msgid "Join Network"
+#~ msgstr "Koble til nettverk"
+
 #~ msgid "Leases"
 #~ msgstr "Leier"
 
@@ -2930,5 +2909,8 @@ msgstr "« Tilbake"
 #~ msgid "Statistics"
 #~ msgstr "Statistikk"
 
+#~ msgid "Submit"
+#~ msgstr "Utfør"
+
 #~ msgid "zone"
 #~ msgstr "Sone"
index 279a8e7..bf40a17 100644 (file)
@@ -961,9 +961,6 @@ msgstr ""
 msgid "IPv4"
 msgstr ""
 
-msgid "IPv4 Firewall"
-msgstr ""
-
 msgid "IPv4 WAN Status"
 msgstr ""
 
@@ -973,9 +970,6 @@ msgstr ""
 msgid "IPv6"
 msgstr ""
 
-msgid "IPv6 Firewall"
-msgstr ""
-
 msgid "IPv6 Setup"
 msgstr ""
 
@@ -1082,9 +1076,6 @@ msgstr ""
 msgid "Java Script required!"
 msgstr ""
 
-msgid "Join Network"
-msgstr ""
-
 msgid "Join Network: Settings"
 msgstr ""
 
@@ -1344,12 +1335,6 @@ msgstr ""
 msgid "Mounted file systems"
 msgstr ""
 
-msgid "Move down"
-msgstr ""
-
-msgid "Move up"
-msgstr ""
-
 msgid "Multicast Rate"
 msgstr ""
 
@@ -1818,9 +1803,6 @@ msgstr ""
 msgid "Save & Apply"
 msgstr ""
 
-msgid "Save &#38; Apply"
-msgstr ""
-
 msgid "Scan"
 msgstr ""
 
@@ -1902,9 +1884,6 @@ msgid ""
 "need to manually flash your device."
 msgstr ""
 
-msgid "Sort"
-msgstr ""
-
 msgid "Source"
 msgstr ""
 
@@ -1962,9 +1941,6 @@ msgstr ""
 msgid "Strict order"
 msgstr ""
 
-msgid "Submit"
-msgstr ""
-
 msgid "Swap Entry"
 msgstr ""