nfs-kernel-server: fix compile issues with uclibc and the new external librpc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Feb 2011 01:45:25 +0000 (01:45 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Feb 2011 01:45:25 +0000 (01:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25499 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/nfs-kernel-server/Makefile
net/nfs-kernel-server/patches/001-nfs_utils_uclibc.patch

index 61324f1..d2420fd 100644 (file)
@@ -64,15 +64,15 @@ define Package/nfs-utils/description
   Updated mount.nfs command - allows mounting nfs4 volumes
 endef
 
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib -I$(STAGING_DIR)/usr/include -Drpc_uint=uint
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(LIBRPC)
+
 CONFIGURE_ARGS += \
        --disable-gss \
        --disable-nfsv4 \
        --enable-static \
        --enable-shared
 
-TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib 
-TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib 
-
 MAKE_FLAGS += \
        OPT="$(TARGET_CFLAGS)" \
        INSTALLSUID="install -m 4755" \
index f6dbf70..8ee831c 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN nfs-utils-1.1.5/utils/mountd/cache.c nfs-utils-1.1.5.new/utils/mountd/cache.c
---- nfs-utils-1.1.5/utils/mountd/cache.c       2009-03-05 12:42:56.000000000 +0100
-+++ nfs-utils-1.1.5.new/utils/mountd/cache.c   2009-04-07 16:11:09.000000000 +0200
-@@ -142,6 +142,7 @@
+--- a/utils/mountd/cache.c
++++ b/utils/mountd/cache.c
+@@ -142,6 +142,7 @@ void auth_unix_gid(FILE *f)
        pw = getpwuid(uid);
        if (!pw)
                rv = -1;
@@ -9,7 +8,7 @@ diff -urN nfs-utils-1.1.5/utils/mountd/cache.c nfs-utils-1.1.5.new/utils/mountd/
        else {
                rv = getgrouplist(pw->pw_name, pw->pw_gid, groups, &ngroups);
                if (rv == -1 && ngroups >= 100) {
-@@ -153,6 +154,7 @@
+@@ -153,6 +154,7 @@ void auth_unix_gid(FILE *f)
                                                  groups, &ngroups);
                }
        }
@@ -17,10 +16,9 @@ diff -urN nfs-utils-1.1.5/utils/mountd/cache.c nfs-utils-1.1.5.new/utils/mountd/
        qword_printint(f, uid);
        qword_printint(f, time(0)+30*60);
        if (rv >= 0) {
-diff -burN nfs-utils-1.1.5/support/nfs/svc_socket.c nfs-utils-1.1.5.p/support/nfs/svc_socket.c
---- nfs-utils-1.1.5/support/nfs/svc_socket.c   2009-03-05 12:42:56.000000000 +0100
-+++ nfs-utils-1.1.5.p/support/nfs/svc_socket.c 2009-04-07 17:33:07.307458029 +0200
-@@ -66,9 +66,13 @@
+--- a/support/nfs/svc_socket.c
++++ b/support/nfs/svc_socket.c
+@@ -66,9 +66,13 @@ svc_socket (u_long number, int type, int
  
    memset (&addr, 0, sizeof (addr));
    addr.sin_family = AF_INET;
@@ -35,3 +33,15 @@ diff -burN nfs-utils-1.1.5/support/nfs/svc_socket.c nfs-utils-1.1.5.p/support/nf
    if (ret == 0 && rpcp != NULL)
      {
        /* First try name.  */
+--- a/utils/statd/sm_inter_svc.c
++++ b/utils/statd/sm_inter_svc.c
+@@ -10,7 +10,9 @@
+ #include <stdlib.h>
+ #include <netdb.h>
+ #include <signal.h>
++#ifndef __UCLIBC__
+ #include <sys/ttycom.h>
++#endif
+ #include <memory.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>