libcli: cleanup, fix cflags
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 10:33:46 +0000 (10:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 10:33:46 +0000 (10:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8269 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libcli/Makefile

index 621771a..65af0ba 100644 (file)
@@ -34,14 +34,11 @@ define Package/libcli
   URL:=http://libcli.sourceforge.net/
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       $(call Build/Compile/Default, \
-               OPTIM="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
-endef
+MAKE_FLAGS += \
+       OPTIM="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install 
 
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include