powerpc: Create a powerpc64 config feature
authorgeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Aug 2009 23:07:45 +0000 (23:07 +0000)
committergeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Aug 2009 23:07:45 +0000 (23:07 +0000)
The config symbol TARGET_ps3 is used in the build files where
special handling for the 64 bit PowerPC processors is needed.
Introduce a new config feature powerpc64, and replace the use
of TARGET_ps3 with powerpc64.

Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17306 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libtwin/Makefile

index 53144c0..63a8068 100644 (file)
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libtwin
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+zlib +libpng +libjpeg @TARGET_ps3
+  DEPENDS:=+zlib +libpng +libjpeg
   TITLE:=The tiny windowing system libraries
   URL:=http://www.t2-project.org/packages/libtwin.html
 endef