move python packages to 'Python' submenu and make them depends on 'python'
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Sep 2007 18:08:06 +0000 (18:08 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Sep 2007 18:08:06 +0000 (18:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8988 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/python/Makefile
lang/python/python-package.mk

index 72d6d40..1dcd5f2 100644 (file)
@@ -26,6 +26,7 @@ PY_DISABLED_MODULES=\
        _curses _curses_panel _tkinter nis 
 
 define Package/python
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   DEPENDS:=+libexpat +libopenssl +libpthread +libreadline +uclibcxx
index c07b465..1b0d9d9 100644 (file)
@@ -24,10 +24,11 @@ define PyPackage
   $(eval $(call PyPackage/$(1)))
 
   define Package/$(1)
+    SUBMENU:=Python
     TITLE:=$(TITLE)
     SECTION:=lang
     CATEGORY:=Languages
-    DEPENDS:=+python
+    DEPENDS:=python
     $(call PyPackage/$(1))
   endef