AA: atheros: backport r36513
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 May 2013 12:07:10 +0000 (12:07 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 May 2013 12:07:10 +0000 (12:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36514 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/atheros/Makefile
target/linux/atheros/patches-3.3/100-board.patch

index ce2a90d..7125f24 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k gpioctl swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards
index aaa4d41..f51a59b 100644 (file)
 +
 --- /dev/null
 +++ b/arch/mips/ar231x/ar2315.c
-@@ -0,0 +1,694 @@
+@@ -0,0 +1,692 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +      if (!is_2315())
 +              return;
 +
-+      gpio_request(AR2315_RESET_GPIO, "reset");
-+
 +      /* Clear any lingering AHB errors */
 +      config = read_c0_config();
 +      write_c0_config(config & ~0x3);