Add dhcpcd (#1797)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Dec 2007 13:41:53 +0000 (13:41 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Dec 2007 13:41:53 +0000 (13:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9778 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/dhcpcd/Makefile [new file with mode: 0644]
net/dhcpcd/patches/001-run_dir.patch [new file with mode: 0644]

diff --git a/net/dhcpcd/Makefile b/net/dhcpcd/Makefile
new file mode 100644 (file)
index 0000000..a8e43f0
--- /dev/null
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dhcpcd
+PKG_VERSION:=3.0.17
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://download.berlios.de/dhcpcd/
+PKG_MD5SUM:=e9100e53f64ca1f9fb0d392c3a623738
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dhcpcd
+  SECTION:=net
+  CATEGORY:=Networking
+  TITLE:=DHCP client for automatically configuring IPv4 networking
+  URL:=http://dhcpcd.berlios.de/
+endef
+
+define Package/dhcpcd/description
+       Simple configuration: supports executions of a script when the
+       IP address changes.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all install
+endef
+
+define Package/dhcpcd/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(CP) $(PKG_INSTALL_DIR)/sbin/* $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,dhcpcd))
+
diff --git a/net/dhcpcd/patches/001-run_dir.patch b/net/dhcpcd/patches/001-run_dir.patch
new file mode 100644 (file)
index 0000000..cbb26ff
--- /dev/null
@@ -0,0 +1,11 @@
+--- dhcpcd-3.0.17/pathnames.h.orig     2007-05-31 15:28:04.000000000 -0700
++++ dhcpcd-3.0.17/pathnames.h  2007-05-31 15:28:16.000000000 -0700
+@@ -48,7 +48,7 @@
+ #define STATEDIR            "/var"
+ #define PIDFILE             STATEDIR "/run/" PACKAGE "-%s.pid"
+-#define CONFIGDIR           STATEDIR "/lib/" PACKAGE
++#define CONFIGDIR           STATEDIR "/run/" PACKAGE
+ #define INFOFILE            CONFIGDIR "/" PACKAGE "-%s.info"
+ #endif