ctorrent:
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Sep 2007 19:48:02 +0000 (19:48 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Sep 2007 19:48:02 +0000 (19:48 +0000)
 * Add libtool fixes
 * Use the g++-uc wrapper the right way (thanks nico)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@9080 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ctorrent/Makefile

index be3d066..ea85c71 100644 (file)
@@ -35,7 +35,18 @@ endef
    
 CONFIGURE_VARS += \
        CXX="g++-uc" \
-       CXXFLAGS="$$$$CXX_CFLAGS -fno-rtti" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+
+define Build/Configure
+       $(call Build/Configure/Default,)
+       $(call libtool_disable_rpath)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+endef
 
 define Package/ctorrent/install        
        $(INSTALL_DIR) $(1)/usr/bin