[patchteam] Wing wireless mesh protocol - fixups for ver. 3
authordingo <dingo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Sep 2010 22:48:00 +0000 (22:48 +0000)
committerdingo <dingo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Sep 2010 22:48:00 +0000 (22:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22993 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/wing/Makefile
net/wing/files/lib/network/wing.sh

index b3300d9..0ce64a4 100644 (file)
@@ -10,9 +10,9 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=wing
 
 ifneq ($(CONFIG_WING_STABLE),)
-       PKG_VERSION:=20100827
-       PKG_RELEASE:=2
-       PKG_REV:=6f238baa6c4f357f1fe0e55f1b71db7816747b33
+       PKG_VERSION:=20100903
+       PKG_RELEASE:=3
+       PKG_REV:=520e3168a5af4d26bec3779cfa4901d128a4bc6f
 else 
        PKG_VERSION:=$(shell date +%Y%m%d)
        PKG_RELEASE:=1
@@ -64,7 +64,7 @@ define Build/Configure
                -f $(PKG_BUILD_DIR)/conf/wing/sample.click \
                -A --all -E Discard -E Print -E Null \
                -E InfiniteSource -E RatedSource -E EtherEncap -E UDPIPEncap \
-               -E AthdescEncap -E AthdescDecap -E RadiotapDecap -E RadiotapEncap \
+               -E RadiotapDecap -E RadiotapEncap \
                -E ProbeTXRate -E MadwifiRate -E AutoRateFallback \
                -E RoundRobinSched -E DRRSched; \
        )
index d721d4c..ac82bb0 100644 (file)
@@ -132,6 +132,7 @@ wing_list_interfaces() {
        config_get device $1 device
        config_get hwmode $device hwmode "11bg"
        freq=$(iwlist $ifname freq | grep "Current Frequency" | sed -n "s/^.*Current Frequency:\([0-9.]*\) GHz (Channel \([0-9]*\))/\1/p" | awk '{print $1*1000}')
+       freq=${freq:-"0"}
        hwaddr=$(/sbin/ifconfig $ifname 2>&1 | sed -n 's/^.*HWaddr \([0-9A-Za-z\-]*\).*/\1/p' | sed -e 's/\-/:/g' | cut -c1-17)
        freqs=${freqs:+"$freqs "}$freq
        hwmodes=${hwmodes:+"$hwmodes "}$hwmode