packages/tinc: fix pid-file arg passed in service command-line
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Nov 2011 13:27:44 +0000 (13:27 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Nov 2011 13:27:44 +0000 (13:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29185 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tinc/Makefile
net/tinc/files/tinc.init

index d18e071..821579d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
 PKG_VERSION:=1.0.16
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages 
index bdbf5bd..e93f0d9 100644 (file)
@@ -164,8 +164,8 @@ start_instance() {
        # append params
        append_params "$s" log debug
 
-       SERVICE_PID_FILE="/var/run/tinc.$s.pid" \
-       service_start $BIN -c "$TMP_TINC/$s" -n $s $ARGS --pidfile="$PID"
+       SERVICE_PID_FILE="/var/run/tinc.$s.pid"
+       service_start $BIN -c "$TMP_TINC/$s" -n $s $ARGS --pidfile="$SERVICE_PID_FILE"
 }
 
 stop_instance() {
@@ -173,7 +173,7 @@ stop_instance() {
 
        section_enabled "$s" || return 1
 
-       SERVICE_PID_FILE="/var/run/tinc.$s.pid" \
+       SERVICE_PID_FILE="/var/run/tinc.$s.pid"
        service_stop $BIN
 }
 
@@ -182,7 +182,7 @@ reload_instance() {
 
        section_enabled "$s" || return 1
 
-       SERVICE_PID_FILE="/var/run/tinc.$s.pid" \
+       SERVICE_PID_FILE="/var/run/tinc.$s.pid"
        service_reload $BIN
 }