mvebu: Replace the padjffs2 call by the generic definition
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Jan 2015 11:37:29 +0000 (11:37 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Jan 2015 11:37:29 +0000 (11:37 +0000)
The mvebu image Makefile directly calls the padjffs2 utility, while there's an
generic make function to do just that. Switch to it

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43968 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mvebu/image/Makefile

index 92571e2..f265dc4 100644 (file)
@@ -44,7 +44,7 @@ define Image/BuildKernel
 endef
 
 define Image/Build/squashfs
-       $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        $(foreach nandboard,$(NANDBOARDS),$(call Image/Build/UbinizeImage,$(nandboard),,squashfs,$(UBI_OPTS));)
        ( \
                dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \