include the forgotten patch for endian detection.
authormazilo <mazilo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Mar 2013 22:39:28 +0000 (22:39 +0000)
committermazilo <mazilo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Mar 2013 22:39:28 +0000 (22:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35841 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/freeswitch/Makefile
net/freeswitch/patches/107-libs-libzrtp-include-zrtp_config_h.patch [new file with mode: 0644]

index 10f5d9c..a4a8e0b 100644 (file)
@@ -18,7 +18,7 @@ PKG_VERSION:=1.3.13b
 #
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-FS_DEFAULT_HEAD:=8258e782d47f4b01c4684b68ecce417298fbbebe
+FS_DEFAULT_HEAD:=c35a41e4ca209f822d561f4601f1f387bfc9a82e
 FS_LATEST_HEAD:=$(shell git ls-remote $(PKG_SOURCE_URL) HEAD | cut -f1)
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_SOFIA_WITH_PULL_CURRENT),$(FS_LATEST_HEAD),$(FS_DEFAULT_HEAD))
 PKG_SOURCE_VERSION_SHORT:=$(shell echo $(PKG_SOURCE_VERSION)|cut -b -7)
diff --git a/net/freeswitch/patches/107-libs-libzrtp-include-zrtp_config_h.patch b/net/freeswitch/patches/107-libs-libzrtp-include-zrtp_config_h.patch
new file mode 100644 (file)
index 0000000..e460bc4
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/libs/libzrtp/include/zrtp_config.h
++++ b/libs/libzrtp/include/zrtp_config.h
+@@ -66,8 +66,16 @@
+  * If the byte order is not specified manually in zrtp_config_user.h - try to detect it automatically
+  */
+ #if !defined(ZRTP_BYTE_ORDER)
++#if defined(linux) || defined(__linux)
+-#if defined(_i386_) || defined(i_386_) || defined(_X86_) || defined(x86) || defined(__i386__) || \
++#include <endian.h>
++#if __BYTE_ORDER == __LITTLE_ENDIAN
++#define ZRTP_BYTE_ORDER ZBO_LITTLE_ENDIAN
++#elif __BYTE_ORDER == __BIG_ENDIAN
++#define ZRTP_BYTE_ORDER ZBO_BIG_ENDIAN
++#endif
++
++#elif defined(_i386_) || defined(i_386_) || defined(_X86_) || defined(x86) || defined(__i386__) || \
+       defined(__i386) || defined(_M_IX86) || defined(__I86__)
+ /*
+  * Generic i386 processor family, little-endian