[packages] haproxy: add transparent mode, needed for SNAT-TPROXY-Load-Balancing which...
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Aug 2010 23:00:57 +0000 (23:00 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Aug 2010 23:00:57 +0000 (23:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22523 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/haproxy/Makefile
net/haproxy/files/haproxy.cfg

index 0f09b53..fcd0243 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
 PKG_VERSION:=1.4.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.4/src
@@ -42,7 +42,7 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)" \
                LD="$(TARGET_CC)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               SMALL_OPTS="-DBUFSIZE=16060 -DMAXREWRITE=8192 -DSYSTEM_MAXCONN=65530" \
+               SMALL_OPTS="-DBUFSIZE=16060 -DMAXREWRITE=8192 -DSYSTEM_MAXCONN=65530" USE_LINUX_TPROXY=1 \
                all install
 endef
 
index 60bcb5b..1c56884 100644 (file)
@@ -77,6 +77,9 @@ listen my_smtp_proxy
        # Round robin load balancing over two servers on port 123 forcing
        # the address 192.168.1.1 and port 25 as source.
        balance roundrobin
+  #use next line for transparent proxy, so the servers can see the 
+  #original ip-address and remove source keyword in server definition
+  #source 0.0.0.0 usesrc clientip
        server server01 192.168.1.10:123 source 192.168.1.1:25
        server server02 192.168.1.20:123 source 192.168.1.1:25