[packages] mysql: fix /bin/hostname invocation in table install script, openwrt does...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Jan 2011 22:41:46 +0000 (22:41 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Jan 2011 22:41:46 +0000 (22:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25182 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/mysql/Makefile
libs/mysql/patches/502-fix-hostname.patch [new file with mode: 0644]

index 9f0d392..dba90cb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mysql
 PKG_VERSION:=5.1.53
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=\
diff --git a/libs/mysql/patches/502-fix-hostname.patch b/libs/mysql/patches/502-fix-hostname.patch
new file mode 100644 (file)
index 0000000..632cb98
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/scripts/mysql_install_db.sh
++++ b/scripts/mysql_install_db.sh
+@@ -317,7 +317,7 @@ then
+ fi
+ # Try to determine the hostname
+-hostname=`@HOSTNAME@`
++hostname=`cat /proc/net/hostname`
+ # Check if hostname is valid
+ if test "$cross_bootstrap" -eq 0 -a "$in_rpm" -eq 0 -a "$force" -eq 0