gnutls tweaks:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Jul 2008 23:31:37 +0000 (23:31 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Jul 2008 23:31:37 +0000 (23:31 +0000)
 - use included libtasn1 library, since gnutls is the only package using it atm
 - use included libcfg library, since it is not packaged yet
 - bump release number

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11996 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gnutls/Makefile

index f7cb18f..42ee26f 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
 PKG_VERSION:=2.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
@@ -70,7 +70,7 @@ endef
 define Package/libgnutls
 $(call Package/gnutls/Default)
  TITLE+= (library)
- DEPENDS+= +zlib +libtasn1 +libgcrypt +libgpg-error
+ DEPENDS+= +zlib +libgcrypt +libgpg-error
 endef
 
 define Package/libgnutls/description
@@ -106,10 +106,11 @@ CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --disable-openpgp-authentication \
+       --with-included-libcfg \
+       --with-included-libtasn1 \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
        --with-libz-prefix="$(STAGING_DIR)/usr" \
-       --with-libtasn1-prefix="$(STAGING_DIR)/usr"
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
 MAKE_ARGS:= \