add missing pppoe-connect script (closes: #1603)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2007 21:00:34 +0000 (21:00 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2007 21:00:34 +0000 (21:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7028 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/rp-pppoe/Makefile

index 55c02ce..ab706b7 100644 (file)
@@ -63,7 +63,8 @@ define Package/rp-pppoe-client/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/scripts/pppoe-{start,stop} $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/scripts/pppoe-{connect,start,stop} $(1)/usr/sbin/
+       $(SED) 's,modprobe,insmod,g' $(1)/usr/sbin/pppoe-connect
 endef
 
 define Package/rp-pppoe-relay/install