cross compile fix
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 17:19:26 +0000 (17:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 17:19:26 +0000 (17:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5092 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/mysql/Makefile
libs/mysql/patches/500-cross_compile.patch

index 912f06f..723492e 100644 (file)
@@ -92,6 +92,7 @@ define Build/Configure
                        --without-docs \
                        --without-bench \
                        --without-readline \
+                       --with-named-thread-libs=-lpthread \
        );
 endef
 
index 9290ab8..e38f7ce 100644 (file)
  
  #
  # Some system specific hacks
+diff -ur mysql.old/include/my_global.h mysql.dev/include/my_global.h
+--- mysql.old/include/my_global.h      Wed Dec 21 20:39:25 2005
++++ mysql.dev/include/my_global.h      Sat Oct 14 19:03:09 2006
+@@ -299,9 +299,11 @@
+ #undef HAVE_ALLOCA
+ #undef HAVE_ALLOCA_H
+ #endif
++#ifdef linux
+ #ifdef HAVE_ALLOCA_H
+ #include <alloca.h>
+ #endif
++#endif
+ #ifdef HAVE_ATOMIC_ADD
+ #define new my_arg_new
+ #define need_to_restore_new 1
+@@ -315,8 +317,10 @@
+ #endif
+ #include <errno.h>                            /* Recommended by debian */
+ /* We need the following to go around a problem with openssl on solaris */
++#ifdef linux
+ #if defined(HAVE_CRYPT_H)
+ #include <crypt.h>
++#endif
+ #endif
+ /*
+diff -ur mysql.old/libmysql/Makefile.in mysql.dev/libmysql/Makefile.in
+--- mysql.old/libmysql/Makefile.in     Wed Dec 21 20:41:18 2005
++++ mysql.dev/libmysql/Makefile.in     Sat Oct 14 19:06:11 2006
+@@ -602,7 +602,7 @@
+       done
+ conf_to_src$(EXEEXT): $(conf_to_src_OBJECTS) $(conf_to_src_DEPENDENCIES) 
+       @rm -f conf_to_src$(EXEEXT)
+-      $(LINK) $(conf_to_src_LDFLAGS) $(conf_to_src_OBJECTS) $(conf_to_src_LDADD) $(LIBS)
++      $(LINK) $(conf_to_src_LDFLAGS) $(conf_to_src_OBJECTS) $(conf_to_src_LDADD)
+ mostlyclean-compile:
+       -rm -f *.$(OBJEXT)