[packages] transmission: use internal miniupnpc, update to 2.83
authorobsy <obsy@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 May 2014 08:58:06 +0000 (08:58 +0000)
committerobsy <obsy@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 May 2014 08:58:06 +0000 (08:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40843 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/transmission/Makefile
net/transmission/patches/020-use-internal-miniupnp.patch [new file with mode: 0644]

index 7273207..3abfecb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
-PKG_VERSION:=2.82
-PKG_RELEASE:=2
+PKG_VERSION:=2.83
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
-PKG_MD5SUM:=a5ef870c0410b12d10449c2d36fa4661
+PKG_MD5SUM:=4620cfbfefee2ce55a6fa12c3ec330a7
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
@@ -32,7 +32,7 @@ endef
 
 define Package/transmission-daemon
   $(call Package/transmission/template)
-  DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt +libminiupnpc
+  DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt
   MENU:=1
 endef
 
@@ -43,7 +43,7 @@ endef
 
 define Package/transmission-remote
   $(call Package/transmission/template)
-  DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt +libminiupnpc
+  DEPENDS:=+libcurl +libopenssl +libpthread +libevent2 +librt
 endef
 
 define Package/transmission-web
diff --git a/net/transmission/patches/020-use-internal-miniupnp.patch b/net/transmission/patches/020-use-internal-miniupnp.patch
new file mode 100644 (file)
index 0000000..cf78567
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -251,7 +251,7 @@
+ AC_LINK_IFELSE(
+   [AC_LANG_PROGRAM([#include <miniupnpc/miniupnpc.h>],
+                    [struct UPNPDev dev;])],
+-  [upnp_version="unknown"],
++  [upnp_version="none"],
+   [upnp_version="none"]
+ )