[packages] samba3: add missing samba-nmbd.init, remove interface setting from config...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Nov 2011 06:08:04 +0000 (06:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Nov 2011 06:08:04 +0000 (06:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29347 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/samba3/Makefile
net/samba3/files/samba-nmbd.init [new file with mode: 0755]
net/samba3/files/smb.conf.template

index eed03f3..e44f550 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba3
 PKG_VERSION:=3.0.37
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MD5SUM:=11ed2bfef4090bd5736b194b43f67289
 
diff --git a/net/samba3/files/samba-nmbd.init b/net/samba3/files/samba-nmbd.init
new file mode 100755 (executable)
index 0000000..5c4428d
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2011 OpenWrt.org
+
+START=61
+
+start() {
+       service_start /usr/sbin/nmbd -D
+}
+
+stop() {
+       service_stop /usr/sbin/nmbd
+}
index 151728f..d3a28df 100644 (file)
@@ -14,4 +14,3 @@
        guest account = nobody
        invalid users = root
        smb passwd file = /etc/samba/smbpasswd
-       interfaces = br-lan