[package] vblade: change config to read-only
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2011 12:44:05 +0000 (12:44 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2011 12:44:05 +0000 (12:44 +0000)
This patch changes the default vbladed config to read-only. It
circumvents data corruption in case of the accidental simultaneous rw
mount.

Signed-off-by: Paul Geraedts <p.f.j.geraedts@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25579 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/vblade/Makefile
net/vblade/files/vblade.config
net/vblade/files/vblade.init

index 9a8afc0..ca5f371 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vblade
 PKG_VERSION:=20
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/aoetools/vblade
index 1f35c07..455988a 100644 (file)
@@ -3,10 +3,12 @@
 #      option slot             '1'
 #      option netif            'eth0'
 #      option device           '/dev/sda'
+#      option options          '-r'
 #
 #config vblade
 #      option shelf            '1'
 #      option slot             '2'
 #      option netif            'eth0'
 #      option device           '/dev/sdb'
+#      option options          '-r'
 #
index bf59d58..afed46b 100644 (file)
@@ -9,7 +9,8 @@ start_service() {
        config_get slot "$section" slot
        config_get netif "$section" netif
        config_get device "$section" device
-       vbladed $shelf $slot $netif $device
+       config_get options "$section" options
+       vbladed $options $shelf $slot $netif $device
 }
 
 start() {