[packages] dovecot: explicitely disable libcap, depend on zlib and libbz2, remove...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Jun 2012 12:37:41 +0000 (12:37 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Jun 2012 12:37:41 +0000 (12:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32335 3c298f89-4303-0410-b956-a3cf2f4a3e73

mail/dovecot/Makefile

index 46deade..e13fd1a 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libopenssl +librt
+  DEPENDS:=+libopenssl +librt +zlib +libbz2
   TITLE:=An IMAP and POP3 daemon
   URL:=http://www.dovecot.org/
 endef
@@ -35,6 +35,7 @@ endef
 CONFIGURE_ARGS += \
        --without-gssapi \
        --without-pam \
+       --without-libcap \
        --with-moduledir=/usr/lib/dovecot/modules \
        --with-notify=dnotify \
 
@@ -51,13 +52,6 @@ CONFIGURE_VARS += \
        lib_cv___va_copy=yes \
        lib_cv_va_val_copy=yes \
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               autoconf \
-       );
-       $(call Build/Configure/Default)
-endef
-
 define Package/dovecot/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot