Update aprx to 0.99 (#3805)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Jul 2008 14:06:26 +0000 (14:06 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Jul 2008 14:06:26 +0000 (14:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11918 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/aprx/Makefile
net/aprx/files/aprx.init [new file with mode: 0644]
net/aprx/patches/100-Makefile_in.patch

index 01bdf18..96e11f0 100644 (file)
@@ -4,17 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
+# $Id: Makefile 2 07/06/2008 18:59:01Z jrhopper@gmail.com$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aprx
-PKG_VERSION:=0.22
-PKG_RELEASE:=svn115
+PKG_VERSION:=0.99
+PKG_RELEASE:=svn121
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE).tar.gz
 PKG_SOURCE_URL:=http://ham.zmailer.org/oh2mqk/aprx
-PKG_MD5SUM:=e376bb1c420858b5053584bae00d498d
+PKG_MD5SUM:=095ec0aa24432196002ae717593bfe5c
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -33,7 +33,15 @@ define Package/aprx/description
        It then forwards appropriate packets to APRS-IS servers.
 endef
 
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --with-embedded \
+       )
+endef
+
 define Package/aprx/install    
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/aprx.init $(1)/etc/init.d/aprx
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/aprx.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/sbin
diff --git a/net/aprx/files/aprx.init b/net/aprx/files/aprx.init
new file mode 100644 (file)
index 0000000..e2dcd89
--- /dev/null
@@ -0,0 +1,23 @@
+#!/bin/sh /etc/rc.common
+#Init script for aprx
+
+START=99
+APRX_BIN="/usr/sbin/aprx"
+APRX_LOG_DIR="/var/log/aprx"
+
+system_config() {
+       local cfg="$1"
+
+       config_get hostname "$cfg" hostname
+}
+
+
+start() {
+       [ -x "$APRX_BIN" ] || return 1
+       [ -d "$APRX_LOG_DIR" ] || mkdir -p $APRX_LOG_DIR
+       $APRX_BIN
+       }
+
+stop() {
+       killall aprx
+}
index 44b8a48..d23f573 100644 (file)
@@ -1,13 +1,14 @@
 diff -ruN aprx-0.22.svn115.orig/Makefile.in aprx-0.22.svn115/Makefile.in
 --- aprx-0.22.svn115.orig/Makefile.in  2008-07-06 17:28:27.000000000 -0400
 +++ aprx-0.22.svn115/Makefile.in       2008-07-06 17:29:42.000000000 -0400
-@@ -25,7 +25,7 @@
+@@ -25,7 +25,8 @@
  CFLAGS=               @CFLAGS@ $(DEFS)
  
  # Linker and flags
 -LD=           @LD@
 +LD=           @CC@
  LDFLAGS=      @LDFLAGS@
++datarootdir = @datarootdir@
  
  INSTALL=      $(srcdir)/install-sh
 @@ -75,10 +75,10 @@