fix screen compile error
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 16:12:30 +0000 (16:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 16:12:30 +0000 (16:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6458 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/screen/Makefile
utils/screen/patches/100-cross_compile_fix.patch

index 8fd73bb..0272726 100644 (file)
@@ -35,10 +35,6 @@ endef
 
 # uses GNU configure
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)
-endef
-
 define Package/screen/install  
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/screen $(1)/usr/sbin/
index a05459f..87e6ddd 100644 (file)
@@ -507,3 +507,24 @@ diff -urN screen-4.0.2.old/pty.c screen-4.0.2.dev/pty.c
  oldlibs="$LIBS"
  LIBS="$LIBS -lsun"
  { echo "$as_me:$LINENO: checking IRIX sun library..." >&5
+diff -ur screen.old/sched.h screen.dev/sched.h
+--- screen.old/sched.h 2002-01-08 16:42:43.000000000 +0100
++++ screen.dev/sched.h 2007-03-02 17:03:48.475830776 +0100
+@@ -22,6 +22,11 @@
+  * $Id$ FAU
+  */
++#ifndef __SCHED_H
++#define __SCHED_H
++
++#include <sys/time.h>
++
+ struct event
+ {
+   struct event *next;
+@@ -41,3 +46,5 @@
+ #define EV_READ               1
+ #define EV_WRITE      2
+ #define EV_ALWAYS     3
++
++#endif