packages/xinetd: fix initscript (closes: #10342)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Nov 2011 12:28:17 +0000 (12:28 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Nov 2011 12:28:17 +0000 (12:28 +0000)
Create a pid file by default when starting xinetd (resolves #10342).

Signed-off-by: Stefan Agner <stefan@agner.ch>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28748 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xinetd/Makefile
net/xinetd/files/xinetd.init

index 9c33cdd..176cfa5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
 PKG_VERSION:=2.3.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xinetd.org/
index a1747f0..c11994b 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 START=50
 
 DEFAULT=/etc/default/xinetd
@@ -9,7 +9,7 @@ PID_F=$RUN_D/xinetd.pid
 start() {
        [ -f $DEFAULT ] && . $DEFAULT
        [ -d $RUN_D ] || mkdir -p $RUN_D
-       xinetd $OPTIONS
+       xinetd -pidfile $PID_F $OPTIONS
 }
 
 stop() {