[packages] radvd: revert r25424 for now as it seems to cause problems in various...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Feb 2011 14:19:19 +0000 (14:19 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Feb 2011 14:19:19 +0000 (14:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25546 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/radvd/Makefile
ipv6/radvd/files/radvd.init

index a2ec0bc..ee95bab 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
 PKG_VERSION:=1.7
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
index 08cd791..dbbe52c 100644 (file)
@@ -196,7 +196,11 @@ radvd_write_prefix() {
        done
        [ "$exist" -eq 0 ] && return 0
 
-       config_get prefixes "$cfg" prefix "::/64"
+       config_get prefixes "$cfg" prefix
+       if [ -z "$prefixes" ]; then
+               prefixes=$(get_ip6addr "$IFNAME") || return 0
+       fi
+
        for prefix in $prefixes; do
                validate_ip6prefix "$prefix" || continue
                printf '\n\tprefix %s\n\t{\n' "$prefix"