sync with buildroot2 from uclibc
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2005 07:40:42 +0000 (07:40 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2005 07:40:42 +0000 (07:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@262 3c298f89-4303-0410-b956-a3cf2f4a3e73

12 files changed:
package/busybox/Makefile.in [deleted file]
package/busybox/busybox.mk
package/dnsmasq/Makefile.in [deleted file]
package/dnsmasq/dnsmasq.mk
package/dropbear_sshd/Makefile.in [deleted file]
package/dropbear_sshd/dropbear_sshd.mk
package/ebtables/Makefile.in [deleted file]
package/ebtables/ebtables.mk
package/iptables/Makefile.in [deleted file]
package/iptables/iptables.mk
package/sed/Makefile.in [deleted file]
package/sed/sed.mk

diff --git a/package/busybox/Makefile.in b/package/busybox/Makefile.in
deleted file mode 100644 (file)
index a8efafb..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_BUSYBOX)),y)
-TARGETS+=busybox
-endif
index 84c4a1c..e19aa7b 100644 (file)
@@ -60,3 +60,12 @@ busybox-clean:
 
 busybox-dirclean:
        rm -rf $(BUSYBOX_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_BUSYBOX)),y)
+TARGETS+=busybox
+endif
diff --git a/package/dnsmasq/Makefile.in b/package/dnsmasq/Makefile.in
deleted file mode 100644 (file)
index 36548bd..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_DNSMASQ)),y)
-TARGETS+=dnsmasq
-endif
index b1848c6..e6b50a2 100644 (file)
@@ -48,3 +48,7 @@ dnsmasq-clean:
 
 dnsmasq-dirclean:
        rm -rf $(DNSMASQ_DIR)
+
+ifeq ($(strip $(BR2_PACKAGE_DNSMASQ)),y)
+TARGETS+=dnsmasq
+endif
diff --git a/package/dropbear_sshd/Makefile.in b/package/dropbear_sshd/Makefile.in
deleted file mode 100644 (file)
index 87247fc..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_DROPBEAR_SSHD)),y)
-TARGETS+=dropbear_sshd
-endif
index 26c9b17..4031e21 100644 (file)
@@ -77,3 +77,6 @@ dropbear_sshd-clean:
 dropbear_sshd-dirclean:
        rm -rf $(DROPBEAR_SSHD_DIR)
 
+ifeq ($(strip $(BR2_PACKAGE_DROPBEAR_SSHD)),y)
+TARGETS+=dropbear_sshd
+endif
diff --git a/package/ebtables/Makefile.in b/package/ebtables/Makefile.in
deleted file mode 100644 (file)
index 20a734f..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_EBTABLES)),y)
-TARGETS+=ebtables
-endif
index b28e86c..e7982ca 100644 (file)
@@ -3,7 +3,7 @@
 # ebtables
 #
 #############################################################
-#
+
 EBTABLES_SOURCE_URL=http://umn.dl.sourceforge.net/sourceforge/ebtables/
 EBTABLES_SOURCE=ebtables-v2.0.6.tar.gz
 EBTABLES_BUILD_DIR=$(BUILD_DIR)/ebtables-v2.0.6
@@ -25,7 +25,7 @@ $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY): $(EBTABLES_BUILD_DIR)/ebtables
        cp -af $(EBTABLES_BUILD_DIR)/ebtables $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
        $(STRIP) $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
 
-ebtables: linux $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
+ebtables: $(TARGET_DIR)/$(EBTABLES_TARGET_BINARY)
 
 ebtables-source: $(DL_DIR)/$(EBTABLES_SOURCE)
 
@@ -35,3 +35,7 @@ ebtables-clean:
 
 ebtables-dirclean:
        rm -rf $(EBTABLES_BUILD_DIR)
+
+ifeq ($(strip $(BR2_PACKAGE_EBTABLES)),y)
+TARGETS+=ebtables
+endif
diff --git a/package/iptables/Makefile.in b/package/iptables/Makefile.in
deleted file mode 100644 (file)
index 5be894b..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_IPTABLES)),y)
-TARGETS+=iptables
-endif
index 99cf14f..e343a61 100644 (file)
@@ -39,7 +39,7 @@ $(TARGET_DIR)/usr/sbin/iptables: $(IPTABLES_BUILD_DIR)/iptables
        $(STRIP) $(TARGET_DIR)/usr/lib/iptables/*.so
        rm -rf $(TARGET_DIR)/usr/man
 
-iptables: $(TARGET_DIR)/usr/sbin/iptables
+iptables: kernel-headers $(TARGET_DIR)/usr/sbin/iptables
 
 iptables-source: $(DL_DIR)/$(IPTABLES_SOURCE)
 
@@ -49,3 +49,7 @@ iptables-clean:
 
 iptables-dirclean:
        rm -rf $(IPTABLES_BUILD_DIR)
+
+ifeq ($(strip $(BR2_PACKAGE_IPTABLES)),y)
+TARGETS+=iptables
+endif
diff --git a/package/sed/Makefile.in b/package/sed/Makefile.in
deleted file mode 100644 (file)
index 6738e4f..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_SED)),y)
-TARGETS+=sed
-endif
index 5154c1f..6377689 100644 (file)
@@ -133,4 +133,6 @@ sed-clean:
 sed-dirclean:
        rm -rf $(SED_DIR2)
 
-
+ifeq ($(strip $(BR2_PACKAGE_SED)),y)
+TARGETS+=sed
+endif