elfutils: remove argp-standalone dependency
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Feb 2013 16:03:09 +0000 (16:03 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Feb 2013 16:03:09 +0000 (16:03 +0000)
It is required only when building elfutils binaries (readelf, ld ...)
but not the library itself.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35558 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/elfutils/Makefile

index 449e790..0aa8d77 100644 (file)
@@ -16,8 +16,6 @@ PKG_MD5SUM:=163a5712b86f6bdfebdf233cc6e2192d
 
 PKG_INSTALL:=1
 
-PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone
-
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
@@ -44,11 +42,6 @@ ifeq ($(CONFIG_BUILD_NLS),y)
 TARGET_LDFLAGS += "-lintl"
 endif
 
-ifdef CONFIG_USE_UCLIBC
-CONFIGURE_VARS += \
-       LIBS="-largp"
-endif
-
 CONFIGURE_ARGS += \
        --disable-werror