ez-ipudate: fix broken endian detection on uClibc
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Nov 2012 12:01:33 +0000 (12:01 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Nov 2012 12:01:33 +0000 (12:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@34057 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ez-ipupdate/Makefile
net/ez-ipupdate/patches/005-endian-detection.patch [new file with mode: 0644]

index 5a5b890..795dc1c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ez-ipupdate
 PKG_VERSION:=3.0.11b8
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/ez-ipupdate \
diff --git a/net/ez-ipupdate/patches/005-endian-detection.patch b/net/ez-ipupdate/patches/005-endian-detection.patch
new file mode 100644 (file)
index 0000000..9efabc6
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/md5.c
++++ b/md5.c
+@@ -35,7 +35,7 @@
+ #include "md5.h"
+-#ifdef _LIBC
++#if defined(_LIBC) || defined(__UCLIBC__)
+ # include <endian.h>
+ # if __BYTE_ORDER == __BIG_ENDIAN
+ #  define WORDS_BIGENDIAN 1