Merge pull request #706 from KevinOConnor/anonidentity-20160407
authorManuel Munz <manu@somakoma.de>
Mon, 25 Apr 2016 14:06:10 +0000 (16:06 +0200)
committerManuel Munz <manu@somakoma.de>
Mon, 25 Apr 2016 14:06:10 +0000 (16:06 +0200)
luci-mod-admin-full: Add option to set anonymous_identity field

applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/model/cbi/ddns/detail.lua
applications/luci-app-ddns/po/de/ddns.po
applications/luci-app-transmission/Makefile
modules/luci-base/luasrc/tools/status.lua
modules/luci-base/luasrc/util.lua

index 2e5fc76..6597a89 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.2
+PKG_VERSION:=2.4.3
 
 # Release == build
 # increase on changes of translation files
index e38a606..131cbfd 100644 (file)
@@ -1086,7 +1086,7 @@ function eif6.parse(self, section, novld)
 end
 
 -- IPv4/IPv6 - bind_network -- ################################################
-if DDNS.has_bindnet or ( ( m:get(section, "bind_network") ) ~= "" ) then
+if DDNS.has_bindnet or ( ( m:get(section, "bind_network") or "" ) ~= "" ) then
        bnet = ns:taboption("advanced", ListValue, "bind_network",
                translate("Bind Network") )
        bnet:depends("ipv4_source", "web")
index 98950b9..54c0de3 100644 (file)
@@ -2,8 +2,8 @@ msgid ""
 msgstr ""
 "Project-Id-Version: luci-app-ddns 2.4.2-1\n"
 "POT-Creation-Date: 2016-02-29 20:55+0100\n"
-"PO-Revision-Date: 2016-02-29 20:58+0100\n"
-"Last-Translator: Christian Schoenebeck <christian.schoenebeck@gmail.com>\n"
+"PO-Revision-Date: 2016-03-29 19:35+0200\n"
+"Last-Translator: Christian Schönebeck <christian.schoenebeck@gmail.com>\n"
 "Language-Team: \n"
 "Language: de\n"
 "MIME-Version: 1.0\n"
@@ -18,19 +18,19 @@ msgid "&"
 msgstr "&"
 
 msgid "-- custom --"
-msgstr ""
+msgstr "-- benutzerdefiniert --"
 
 msgid "-- default --"
 msgstr "-- Standard --"
 
 msgid "Advanced Settings"
-msgstr ""
+msgstr "Erweiterte Einstellungen"
 
 msgid "Allow non-public IP's"
 msgstr "Erlaube Nicht-öffentliche IPs"
 
 msgid "Applying changes"
-msgstr ""
+msgstr "Änderungen anwenden"
 
 msgid "Basic Settings"
 msgstr "Grundlegende Einstellungen"
@@ -84,13 +84,13 @@ msgid "Check Interval"
 msgstr "Prüfinterval"
 
 msgid "Collecting data..."
-msgstr ""
+msgstr "Sammle Daten..."
 
 msgid "Config error"
 msgstr "Konfigurationsfehler"
 
 msgid "Configuration"
-msgstr ""
+msgstr "Einstellungen"
 
 msgid ""
 "Configure here the details for all Dynamic DNS services including this LuCI "
@@ -210,7 +210,7 @@ msgstr ""
 "laufenden Konfigurationen."
 
 msgid "Disabled"
-msgstr ""
+msgstr "Deaktiviert"
 
 msgid "Domain"
 msgstr "Domäne"
@@ -229,10 +229,10 @@ msgid "Enable secure communication with DDNS provider"
 msgstr "Aktiviert sichere Kommunikation mit dem DDNS Anbieter"
 
 msgid "Enabled"
-msgstr ""
+msgstr "Aktiviert"
 
 msgid "Error"
-msgstr ""
+msgstr "Fehler"
 
 msgid "Error Retry Counter"
 msgstr "Wiederholungszähler bei Fehler"
@@ -244,7 +244,7 @@ msgid "Event Network"
 msgstr "Ereignis Netzwerk"
 
 msgid "File"
-msgstr ""
+msgstr "Datei"
 
 msgid "File not found"
 msgstr "Datei nicht gefunden"
@@ -295,7 +295,7 @@ msgstr ""
 "physikalische Schnittstelle."
 
 msgid "Global Settings"
-msgstr ""
+msgstr "Globale Einstellungen"
 
 msgid "HTTPS not supported"
 msgstr "HTTPS nicht unterstützt"
@@ -315,7 +315,7 @@ msgid "IP address version"
 msgstr "IP-Adressversion"
 
 msgid "IPv4-Address"
-msgstr ""
+msgstr "IPv4-Adresse"
 
 msgid "IPv6 address must be given in square brackets"
 msgstr "Eine IPv6 Adresse muss in eckigen Klammern angegeben werden"
@@ -333,7 +333,7 @@ msgid "IPv6 not supported"
 msgstr "IPv6 nicht unterstützt"
 
 msgid "IPv6-Address"
-msgstr ""
+msgstr "IPv6-Adresse"
 
 msgid "If both cURL and GNU Wget are installed, Wget is used by default."
 msgstr "Wenn cURL und GNU Wget installiert sind, wird Wget verwendet."
@@ -364,7 +364,7 @@ msgstr ""
 "compiliert."
 
 msgid "Info"
-msgstr ""
+msgstr "Info"
 
 msgid ""
 "Install ca-certificates package or needed certificates by hand into /etc/ssl/"
@@ -374,7 +374,7 @@ msgstr ""
 "von Hand in das Standardverzeichnis /etc/ssl/certs"
 
 msgid "Interface"
-msgstr ""
+msgstr "Schnittstelle"
 
 msgid ""
 "Interval to check for changed IP<br />Values below 5 minutes == 300 seconds "
@@ -401,7 +401,7 @@ msgid "Last Update"
 msgstr "Letztes Aktualisierung"
 
 msgid "Loading"
-msgstr ""
+msgstr "Lade"
 
 msgid "Log File Viewer"
 msgstr "Protokolldatei"
@@ -439,7 +439,7 @@ msgstr ""
 "HTTPS Protokoll zu unterstützen."
 
 msgid "Network"
-msgstr ""
+msgstr "Netzwerk"
 
 msgid "Network on which the ddns-updater scripts will be started"
 msgstr "Netzwerk auf dem Ereignisse die ddns-updater Skripte starten"
@@ -463,7 +463,7 @@ msgid "Non-public and by default blocked IP's"
 msgstr "Nicht-öffentliche und standardmäßig blockierte IPs."
 
 msgid "Notice"
-msgstr ""
+msgstr "Notiz"
 
 msgid "Number of last lines stored in log files"
 msgstr ""
@@ -512,7 +512,7 @@ msgid "Optional: Replaces [PARAMOPT] in Update-URL (NOT URL-encoded)"
 msgstr "Optional: Ersetzt [PARAMENC] in der Update-URL (NICHT URL-codiert)"
 
 msgid "Overview"
-msgstr ""
+msgstr "Übersicht"
 
 msgid "PROXY-Server"
 msgstr "Proxy-Server"
@@ -521,10 +521,10 @@ msgid "PROXY-Server not supported"
 msgstr "Proxy-Server nicht unterstützt"
 
 msgid "Password"
-msgstr ""
+msgstr "Passwort"
 
 msgid "Path to CA-Certificate"
-msgstr ""
+msgstr "Pfad zum CA-Zertifikat"
 
 msgid "Please [Save & Apply] your changes first"
 msgstr "Bitte [Speichern & Anwenden] Sie Änderungen zunächst"
@@ -572,7 +572,7 @@ msgid "Specifying a DNS-Server is not supported"
 msgstr "Die Angabe eines DNS-Server wird nicht unterstützt"
 
 msgid "Start"
-msgstr ""
+msgstr "Start"
 
 msgid "Start / Stop"
 msgstr "Start / Stopp"
@@ -636,25 +636,25 @@ msgstr ""
 "wird."
 
 msgid "Username"
-msgstr ""
+msgstr "Benutzername"
 
 msgid "Using specific DNS Server not supported"
 msgstr "Verwendung spezifischer DNS-Server wird nicht unterstützt"
 
 msgid "Verify"
-msgstr ""
+msgstr "Überprüfen"
 
 msgid "Version"
-msgstr ""
+msgstr "Version"
 
 msgid "Version Information"
 msgstr "Versionsinformationen"
 
 msgid "Waiting for changes to be applied..."
-msgstr ""
+msgstr "Änderungen werden angewandt..."
 
 msgid "Warning"
-msgstr ""
+msgstr "Warnung"
 
 msgid ""
 "Writes detailed messages to log file. File will be truncated automatically."
@@ -738,7 +738,7 @@ msgid "file or directory not found or not 'IGNORE'"
 msgstr "Datei oder Verzeichnis nicht gefunden oder nicht 'IGNORE'"
 
 msgid "help"
-msgstr ""
+msgstr "Hilfe"
 
 msgid "hours"
 msgstr "Stunden"
index 45175b7..668c731 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+# Copyright (C) 2008-2016 The LuCI Team <luci@lists.subsignal.org>
 #
 # This is free software, licensed under the Apache License, Version 2.0 .
 #
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Transmission
-LUCI_DEPENDS:=+transmission-daemon
+LUCI_DEPENDS:=
 
 include ../../luci.mk
 
index ac053ea..a1ecbe7 100644 (file)
@@ -48,7 +48,15 @@ local function dhcp_leases_common(family)
                fd:close()
        end
 
-       local fd = io.open("/tmp/hosts/odhcpd", "r")
+       local lease6file = "/tmp/hosts/odhcpd"
+       uci:foreach("dhcp", "odhcpd",
+               function(t)
+                       if t.leasefile and nfs.access(t.leasefile) then
+                               lease6file = t.leasefile
+                               return false
+                       end
+               end)
+       local fd = io.open(lease6file, "r")
        if fd then
                while true do
                        local ln = fd:read("*l")
index d614a6c..896e36b 100644 (file)
@@ -640,18 +640,18 @@ function checklib(fullpathexe, wantedlib)
        local fs = require "nixio.fs"
        local haveldd = fs.access('/usr/bin/ldd')
        if not haveldd then
-               return -1
+               return false
        end
        local libs = exec("/usr/bin/ldd " .. fullpathexe)
        if not libs then
-               return 0
+               return false
        end
        for k, v in ipairs(split(libs)) do
                if v:find(wantedlib) then
-                       return 1
+                       return true
                end
        end
-       return 0
+       return false
 end
 
 --