[PATCH] [dsl-qos-queue] Add libipq to DEPENDS, and reference shared library, since...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Aug 2010 17:14:11 +0000 (17:14 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Aug 2010 17:14:11 +0000 (17:14 +0000)
This fixes the build of this package and makes it work again.
Signed-off-by: Ithamar R. Adema <ithamar.adema@team-embedded.nl>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22489 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/dsl-qos-queue/Makefile

index 99a2d3e..e3d0739 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
+  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt +libipq @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
   TITLE:=ADSL/ATM Bandwith management
   URL:=http://www.sonicspike.net/software/
 endef
@@ -34,7 +34,7 @@ define Build/Compile
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.a \
+               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.so \
                all \
        )
 endef