[packages_10.03.2] hiawatha: merge r28232, r28479, r28480, r29360
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 19:58:49 +0000 (19:58 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 19:58:49 +0000 (19:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30095 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/hiawatha/Makefile

index adc48f3..943a57c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
-PKG_VERSION:=7.3
-PKG_RELEASE:=1
+PKG_VERSION:=7.8.2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
-PKG_MD5SUM:=52fd6bf798c07298e12ff69b882f3d76
+PKG_MD5SUM:=8aff3f8c759871ea1d1ff22e98030332
+
+PKG_CONFIG_DEPENDS:= \
+       CONFIG_IPV6 \
 
 PKG_INSTALL:=1
 
@@ -26,14 +29,15 @@ define Package/hiawatha
   TITLE:=A very lightweight web server
   URL:=http://www.hiawatha-webserver.org/
   MAINTAINER:=RaphaĆ«l HUCK <rhk@cksum.org>
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +zlib
 endef
 
 define Package/hiawatha/description
-Hiawatha is an open source webserver with a focus on security.
+  Hiawatha is an open source webserver with a focus on security.
 endef
 
 CONFIGURE_ARGS+= \
+       $(call autoconf_bool,CONFIG_IPV6,ipv6) \
        --disable-cache \
        --disable-monitor \
        --disable-ssl \