image.mk: use cross toolchain cpp for processing dts file instead of relying on the...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2015 11:15:41 +0000 (11:15 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2015 11:15:41 +0000 (11:15 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47937 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 6b2fb1a..1522dd7 100644 (file)
@@ -142,7 +142,7 @@ endef
 # $(3) extra CPP flags
 # $(4) extra DTC flags
 define Image/BuildDTB
-       $(CPP) -nostdinc -x assembler-with-cpp \
+       $(TARGET_CROSS)cpp -nostdinc -x assembler-with-cpp \
                -I$(DTS_DIR) \
                -I$(DTS_DIR)/include \
                -undef -D__DTS__ $(3) \