work around permission problems in the avrdude tarball - fixes avr32 compile error
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 16:31:28 +0000 (16:31 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 16:31:28 +0000 (16:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12912 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/avrdude/Makefile

index 8ba1608..adfa268 100644 (file)
@@ -30,6 +30,11 @@ define Package/avrdude/description
  AVRDUDE is a full featured program for programming Atmel's AVR CPU's.
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       chmod -R u+w $(PKG_BUILD_DIR)
+endef
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --disable-static \