[packages] openssh: if CONFIG_OPENSSL_ENGINE is defined compile with --with-ssl-engine
authortripolar <tripolar@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Nov 2011 00:51:20 +0000 (00:51 +0000)
committertripolar <tripolar@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Nov 2011 00:51:20 +0000 (00:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29087 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openssh/Makefile

index d668be4..527bd98 100644 (file)
@@ -127,6 +127,11 @@ CONFIGURE_ARGS+= \
        --without-pam \
        --without-x
 
+ifdef CONFIG_OPENSSL_ENGINE
+CONFIGURE_ARGS+= \
+       --with-ssl-engine
+endif
+
 ifneq ($(CONFIG_SSP_SUPPORT),y)
 CONFIGURE_ARGS += \
        --without-stackprotect