Update posgresql to 8.3.3 (#3591)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 17:31:31 +0000 (17:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 17:31:31 +0000 (17:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11727 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/postgresql/Makefile
libs/postgresql/patches/200-ranlib.patch
libs/postgresql/patches/800-busybox-default-pager.patch
libs/postgresql/patches/850-uclibc_no_cbrt.patch

index d3b7756..8972651 100644 (file)
@@ -9,10 +9,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=8.3.1
+PKG_VERSION:=8.3.3
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
        http://ftp7.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
@@ -20,12 +19,10 @@ PKG_SOURCE_URL:=\
        http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
        http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=a5e0ed6a85b450dc217ec71da93243a7
+PKG_MD5SUM:=0ae4bd9620e84d3e08dcf923808d14d0
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libpq
index a33eb74..03c16cb 100644 (file)
@@ -1,7 +1,5 @@
-Index: postgresql-8.3.0/src/port/Makefile
-===================================================================
---- postgresql-8.3.0.orig/src/port/Makefile    2008-02-06 16:27:48.000000000 -0600
-+++ postgresql-8.3.0/src/port/Makefile 2008-02-06 16:28:18.000000000 -0600
+--- a/src/port/Makefile
++++ b/src/port/Makefile
 @@ -49,6 +49,7 @@
  
  libpgport.a: $(OBJS)
index 0587f35..0605e9f 100644 (file)
@@ -1,7 +1,5 @@
-Index: postgresql-8.3.0/src/bin/psql/print.h
-===================================================================
---- postgresql-8.3.0.orig/src/bin/psql/print.h 2008-01-01 13:45:56.000000000 -0600
-+++ postgresql-8.3.0/src/bin/psql/print.h      2008-02-06 16:29:56.000000000 -0600
+--- a/src/bin/psql/print.h
++++ b/src/bin/psql/print.h
 @@ -89,10 +89,6 @@
  
  void          setDecimalLocale(void);
index f60f0f2..3f922b8 100644 (file)
@@ -1,7 +1,5 @@
-Index: postgresql-8.3.0/src/backend/utils/adt/float.c
-===================================================================
---- postgresql-8.3.0.orig/src/backend/utils/adt/float.c        2008-01-01 13:45:52.000000000 -0600
-+++ postgresql-8.3.0/src/backend/utils/adt/float.c     2008-02-06 16:30:02.000000000 -0600
+--- a/src/backend/utils/adt/float.c
++++ b/src/backend/utils/adt/float.c
 @@ -71,7 +71,9 @@
  static int    float8_cmp_internal(float8 a, float8 b);