Fix ssmtp compilation
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 16:31:38 +0000 (16:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 16:31:38 +0000 (16:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8629 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ssmtp/Makefile

index 13d53e3..331f2b7 100644 (file)
@@ -32,9 +32,11 @@ define Package/ssmtp
   URL:=http://packages.debian.org/stable/mail/ssmtp
 endef
 
-EXTRA_LDFLAGS+=-Wl,-rpath-link,$(STAGING_DIR)/usr/lib
+EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
+
 TARGET_CONFIGURE_OPTS+=\
-       CC="$(TARGET_CC) $(EXTRA_LDFLAGS)"
+       CC="$(TARGET_CC) $(EXTRA_CFLAGS) $(EXTRA_LDFLAGS)"
 
 CONFIGURE_ARGS += \
        --enable-ssl