toolchain/gcc: fix build on arm with clang as host gcc replacement
authorFelix Fietkau <nbd@openwrt.org>
Thu, 15 May 2014 20:11:54 +0000 (20:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 15 May 2014 20:11:54 +0000 (20:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40772 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/common.mk

index af971ba..5dfbc48 100644 (file)
@@ -95,6 +95,10 @@ endif
 
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
+       $(if $(shell gcc --version 2>&1 | grep LLVM), \
+               CFLAGS="-O2 -fbracket-depth=512 -pipe" \
+               CXXFLAGS="-O2 -fbracket-depth=512 -pipe" \
+       ) \
        $(HOST_SOURCE_DIR)/configure \
                --with-bugurl=$(BUGURL) \
                --with-pkgversion="$(PKGVERSION)" \