petitboot: Use uname for hostname
authorgeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Feb 2013 01:05:37 +0000 (01:05 +0000)
committergeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Feb 2013 01:05:37 +0000 (01:05 +0000)
Signed-off-by: Geoff Levand <geoff@infradead.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35742 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/petitboot/Makefile

index 4e072ea..4ae52e8 100644 (file)
@@ -72,7 +72,7 @@ petitboot-install-autorun-$(CONFIG_PETITBOOT_AUTORUN_GUI) = \
        ln -sf pb-twin $(1)/usr/sbin/petitboot
 
 CONFIGURE_ARGS += $(petitboot-config-args-y) \
-       PACKAGE_VERSION=$(shell echo ${HOSTNAME})-$(shell date +%y.%m.%d-%H.%M)
+       PACKAGE_VERSION=$(shell uname -n)-$(shell date +%y.%m.%d-%H.%M)
 
 EXTRA_CPPFLAGS += $(petitboot-cppflags-y)