joe:
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 23 Aug 2007 11:59:03 +0000 (11:59 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 23 Aug 2007 11:59:03 +0000 (11:59 +0000)
 * Fix libncurses dependency (closes: #2265)
 * Cleanup Makefile
 * Refresh patch

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8464 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/joe/Makefile
utils/joe/patches/001-mathaway.patch

index 892fe6d..c4c8298 100644 (file)
@@ -15,24 +15,21 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/joe-editor
 PKG_MD5SUM:=9bdffecce7ef910feaa06452d48843de
-PKG_CAT:=zcat
 
 PKG_BUILD_DEPENDS:=libncurses
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/joe
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+libncurses
   TITLE:=JOE - Joes own editor
   DESCRIPTION:=Joe is world-famous Wordstar like text editor.
   URL:=http://sourceforge.net/projects/joe-editor/
 endef
 
 define Package/joe/install
-       $(STRIP) $(PKG_BUILD_DIR)/joe
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/joe $(1)/usr/bin/
 endef
index f90c57e..6cb3d20 100644 (file)
@@ -1,5 +1,7 @@
---- joe-3.5/umath.c    2007-03-17 09:26:29.000000000 +0100
-+++ joe-3.5/umath.c.new        2007-03-17 09:27:54.000000000 +0100
+Index: joe-3.5/umath.c
+===================================================================
+--- joe-3.5.orig/umath.c       2007-08-23 13:56:53.000000000 +0200
++++ joe-3.5/umath.c    2007-08-23 13:56:53.000000000 +0200
 @@ -378,7 +378,6 @@
  double m_tan(double n) { return tan(n); }
  double m_exp(double n) { return exp(n); }