[PATCH] tinyproxy: allow to use the bind option
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 May 2011 09:09:58 +0000 (09:09 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 May 2011 09:09:58 +0000 (09:09 +0000)
Attached patch allows to use the 'bind' option even if transparent proxy
support is compiled into tinyproxy (which is in openwrt). There are
several references related to the bug, but nobody seams to know why this
- apparently not needed - check was build in.

Regards
Mathias

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26982 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tinyproxy/Makefile
net/tinyproxy/patches/010-no-docs-and-tests.patch
net/tinyproxy/patches/020-config_and_pid-path.patch
net/tinyproxy/patches/030-allow_bind_in_transparent_mode.patch [new file with mode: 0644]

index f219a09..e3dae22 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
 PKG_VERSION:=1.8.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
index 12298e6..9845c35 100644 (file)
@@ -12,7 +12,7 @@
  ACLOCAL_AMFLAGS = -I m4macros
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -221,9 +221,7 @@ SUBDIRS = \
+@@ -222,9 +222,7 @@ SUBDIRS = \
        src \
        data \
        etc \
index 2e9f9e4..3ab7482 100644 (file)
@@ -1,7 +1,6 @@
-diff -Nur a/src/main.c b/src/main.c
---- a/src/main.c        2010-07-17 11:57:25.000000000 +0200
-+++ b/src/main.c        2010-07-17 11:58:52.000000000 +0200
-@@ -326,8 +326,8 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -326,8 +326,8 @@ static void initialize_config_defaults (
          conf->errorpages = NULL;
          conf->stathost = safestrdup (TINYPROXY_STATHOST);
          conf->idletimeout = MAX_IDLE_TIME;
@@ -12,4 +11,3 @@ diff -Nur a/src/main.c b/src/main.c
  }
  
  /**
-
diff --git a/net/tinyproxy/patches/030-allow_bind_in_transparent_mode.patch b/net/tinyproxy/patches/030-allow_bind_in_transparent_mode.patch
new file mode 100644 (file)
index 0000000..7d6decd
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/src/conf.c
++++ b/src/conf.c
+@@ -857,7 +857,6 @@ static HANDLE_FUNC (handle_deny)
+ static HANDLE_FUNC (handle_bind)
+ {
+-#ifndef TRANSPARENT_PROXY
+         int r = set_string_arg (&conf->bind_address, line, &match[2]);
+         if (r)
+@@ -865,11 +864,6 @@ static HANDLE_FUNC (handle_bind)
+         log_message (LOG_INFO,
+                      "Outgoing connections bound to IP %s", conf->bind_address);
+         return 0;
+-#else
+-        fprintf (stderr,
+-                 "\"Bind\" cannot be used with transparent support enabled.\n");
+-        return 1;
+-#endif
+ }
+ static HANDLE_FUNC (handle_listen)