[package] update htpdate to 1.0.4 (#5550)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Jul 2009 15:10:59 +0000 (15:10 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Jul 2009 15:10:59 +0000 (15:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16945 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/htpdate/Makefile
net/htpdate/patches/100-adjtimex.patch

index 53ca847..8c1e9e3 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htpdate
-PKG_VERSION:=1.0.1
+PKG_VERSION:=1.0.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.clevervest.com/htp/archive/c/
-PKG_MD5SUM:=a0c2b7a3e89a9fedb1ae8cba17928ec3
+PKG_MD5SUM:=a13ec89839c33965794ebf53c4e690db
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,18 +37,17 @@ define Package/htpdate/conffiles
 /etc/default/htpdate
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)"
 endef
 
-
-define Package/htpdate/install 
+define Package/htpdate/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/htpdate $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/default/
-       $(INSTALL_DATA) ./files/htpdate.default $(1)/etc/default/htpdate
+       $(INSTALL_CONF) ./files/htpdate.default $(1)/etc/default/htpdate
        $(INSTALL_DIR) $(1)/etc/init.d/
        $(INSTALL_BIN) ./files/htpdate.init $(1)/etc/init.d/htpdate
 endef
index 7551885..ec7c8a9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/htpdate.c
 +++ b/htpdate.c
-@@ -349,7 +349,7 @@
+@@ -359,7 +359,7 @@ static int htpdate_adjtimex( double drif
  
        /* Read current kernel frequency */
        tmx.modes = 0;
@@ -9,12 +9,12 @@
  
        /* Calculate new frequency */
        freq = (long)(65536e6 * drift);
-@@ -364,7 +364,7 @@
+@@ -377,7 +377,7 @@ static int htpdate_adjtimex( double drif
+               printlog( 1, "seteuid()" );
+               exit(1);
+       } else {
+-              return( ntp_adjtime(&tmx) );
++              return( adjtimex(&tmx) );
+       }
  
-       /* Become root */
-       seteuid(0);
--      return( ntp_adjtime(&tmx) );
-+      return( adjtimex(&tmx) );
  }