Fix at compilation
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Sep 2008 15:09:44 +0000 (15:09 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Sep 2008 15:09:44 +0000 (15:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12643 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/at/Makefile

index f40c396..f793ffa 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/at
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+libelf
   TITLE:=Delayed job execution and batch processing
 endef
 
@@ -30,7 +31,8 @@ define Package/at/description
 endef
 
 export SENDMAIL=/bin/true
-EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR)
+EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include/libelf \
+               -L$(STAGING_DIR)/usr/lib
 CONFIGURE_ARGS+=--with-daemon_username=nobody --with-daemon_groupname=nogroup
 
 define Package/at/install