packages/baresip: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Nov 2011 09:44:09 +0000 (09:44 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Nov 2011 09:44:09 +0000 (09:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29171 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/baresip/Makefile
net/baresip/files/baresip.init

index 1340e46..c389ab8 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=baresip
 PKG_VERSION:=0.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub/
index d0f5a24..e398595 100644 (file)
@@ -1,17 +1,14 @@
 #!/bin/sh /etc/rc.common
-#
 # Copyright (C) 2010-2011 OpenWrt.org
 # Copyright (C) 2010 Alfred E. Heggestad
 #
 
 START=92
-BIN=baresip
-OPTIONS=-d
 
 start() {
-       start-stop-daemon -S -q -x $BIN -- $OPTIONS
+       service_start /usr/bin/baresip -d
 }
 
 stop() {
-       start-stop-daemon -K -q -x $BIN
+       service_stop /usr/bin/baresip
 }