add modules.d file for wl
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Jun 2006 20:30:20 +0000 (20:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Jun 2006 20:30:20 +0000 (20:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4011 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/broadcom-wl/Makefile

index 782dfda..497f392 100644 (file)
@@ -71,6 +71,8 @@ define Build/Compile
 endef
 
 define Package/kmod-brcm-wl/install
+       install -d -m0755 $(1)/etc/modules.d
+       echo "wl" > $(1)/etc/modules.d/20-wl
        install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
        install -m0644 $(PKG_BUILD_DIR)/kmod/wl.o $(1)/lib/modules/$(LINUX_VERSION)/
 endef