[package] cleanup ezxml makefile, compile with fpic and install static libraries...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 May 2009 14:49:13 +0000 (14:49 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 May 2009 14:49:13 +0000 (14:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16087 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/ezxml/Makefile

index b9c6cf2..07fb26a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ezxml
 PKG_VERSION:=0.8.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ezxml
@@ -35,17 +35,14 @@ define Package/libezxml/description
        ezXML is a fast and lightweight C library for parsing XML documents.
 endef
 
-TARGET_CFLAGS += -D_GNU_SOURCE
+TARGET_CFLAGS += $(FPIC) -D_GNU_SOURCE
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/ezxml.h $(1)/usr/include/
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libezxml.a $(1)/usr/lib/
-
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libezxml.so $(1)/usr/lib/
+       $(CP) $(PKG_BUILD_DIR)/libezxml.{a,so} $(1)/usr/lib/
 endef
 
 define Package/libezxml/install