smartmontools: Made the init script executable on installation
authorrwhitby <rwhitby@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Jul 2007 08:15:45 +0000 (08:15 +0000)
committerrwhitby <rwhitby@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Jul 2007 08:15:45 +0000 (08:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7931 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/smartmontools/Makefile

index c35d2d7..44f3190 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
 PKG_VERSION:=5.37
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
@@ -55,7 +55,7 @@ define Package/smartmontools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/smartd.conf $(1)/etc
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/smartd.init $(1)/etc/init.d/smartd
+       $(INSTALL_BIN) ./files/smartd.init $(1)/etc/init.d/smartd
 endef
 
 $(eval $(call BuildPackage,smartmontools))