fcgi: replace cflags based uclibc++ hacks with using the g++-uc wrapper - fixes false...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 20:33:35 +0000 (20:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 20:33:35 +0000 (20:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32203 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/fcgi/Makefile

index 26487c5..f0dc317 100644 (file)
@@ -36,7 +36,7 @@ endef
 
 define Package/fcgixx
   $(call Package/fcgi/Default)
-  DEPENDS:=fcgi +USE_UCLIBC:uclibcxx
+  DEPENDS:=fcgi +uclibcxx
   TITLE:=Shared library of FastCGI++
 endef
 
@@ -46,6 +46,7 @@ define Package/fcgi/description
  server specific APIs.
 endef
 
+TARGET_CXX=g++-uc
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
@@ -53,9 +54,7 @@ CONFIGURE_ARGS += \
        --enable-static \
 
 CONFIGURE_VARS += \
-       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
-       LIBS="-nodefaultlibs -lc -luClibc++ -lm" \
+       LIBS="-lm" \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include